注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

祥磊部落网易博客

祥磊部落:http://www.bxl.me

 
 
 

日志

 
 

<!--:zh-->kloxo - 设置suphp出现500错误方法<!--:-->  

2014-02-07 07:35:38|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
查看原文:http://bxl.me/3866.html

500错误原因:
由于PHP版本兼容性的问题,导致php-cgi、apache都不能使用suphp。处理办法,只能把PHP先降级,然后安装好SUphp后再重新升级


备份好php.ini


cd /etc
yes | cp -rf php.ini php.ini.bck
cd /

降级老版本的PHP


rpm -e --nodeps php
rpm -e --nodeps php-cli
rpm -e --nodeps php-common
rpm -e --nodeps php-fpm
yum install php-5.2.17-1

?复制到旧版本?


yes | cp -rf /usr/bin/php /usr/bin/php_pure
yes | cp -rf /usr/bin/php-cgi /usr/bin/php-cgi_pure

?重新编译旧版本的SUPHP


cd /usr/local/lxlabs/kloxo/file/
yes | cp -rf etc_suphp.conf etc_suphp.conf.orig
sed -i 's/\/usr\/bin\/php-cgi"/\/usr\/bin\/php-cgi_pure"/' etc_suphp.conf
cd /etc
sed -i 's/\/usr\/bin\/php-cgi"/\/usr\/bin\/php-cgi_pure"/' suphp.conf

?恢复以前的php.ini


yes | cp -rf php.ini.bck php.ini
cd /

?再升级PHP


yum upgrade php*

然后重启服务器


reboot



  评论这张
 
阅读(47)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017