注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

祥磊部落网易博客

祥磊部落:http://www.bxl.me

 
 
 

日志

 
 

Virtualmin/Webmin - 升级php到5.2.17  

2014-11-06 23:46:16|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
查看原文:http://www.bxl.me/7723.html
因为有些时候我们安装webmin的时候默认是5.1,现在很多的程序都不支持php5.1了,主要也就是更新源有问题而已

替换源


我们使用VI命令编辑相应的文件首先在SSH命令行输入:
vi /etc/yum.repos.d/utterrambling.repo

如提示vi命令不存的可以用下面这个命令:
vim /etc/yum.repos.d/utterrambling.repo

32位源


[utterramblings]
name=Jason’s Utter Ramblings Repo
baseurl=http://yum.jasonlitka.com/EL5/i386/
enabled=1
gpgcheck=1
gpgkey=http://yum.jasonlitka.com/RPM-GPG-KEY-jlitka

?64位源


[utterramblings]
name=Jason’s Utter Ramblings Repo
baseurl=http://yum.jasonlitka.com/EL5/x86_64/
enabled=1
gpgcheck=1
gpgkey=http://yum.jasonlitka.com/RPM-GPG-KEY-jlitka

保存推出后我们就可以使用

升级PHP


yum -y upgrade php

对PHP进行升级了

查看PHP版本


然后我们用
php -v

看看是不是php5.2.17

linode-webmin-php5.2.17

 

 

忽然想到有些小白不会使用VI命令,那我就直接将文件上传上来,自己在相应目录替换掉就好了。

php5.2.17-centos-5

自己选择到底使用的是32位的系统还是64位的系统进行替换就好了。

然后使用上面的升级PHP就OK了。
yum -y upgrade php

 

以上演示选自linode 日本机房 20$配置的Centos5的操作系统


  评论这张
 
阅读(64)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017